Receiving Customer Files

Updated 4-2004

For Signworld Use Only

This is a 2004 update to a document that was originally created in the year 2000. It contains procedures for most commonly used application programs which are in widespread use today by the graphic arts community. We have also enhanced the completeness of this update by including procedures for Microsoft Office applications such as PowerPoint, Word, and Excel.

The Absolute Solution:

Without question, the most comprehensive solution would involve the exact reproduction of your customer’s computing environment. This includes the same computing platforms (Macintosh, PC/ Windows, Unix), Application Programs (including revision, such as Photoshop, Illustrator, Freehand, Quark, PageMaker, InDesign, and more). Also, don’t forget to include the exact same set of fonts that your customers are using. While this is exactly what the traditional Service Bureau for the graphic arts industry has been doing for years, it is a very expensive proposition, and one that most sign companies are not willing to seriously consider.

Problem Areas:

While FlexiSIGN (through version 7.5v4) and CorelDraw/ Photo PAINT (through version 12) are making strides in this area, problems can still arise. Over the years, we (and many others) have been making general statements advising the use of one file format over another, or to convert text to curves in the design application. These are valid suggestions, but they tend to fall short of optimal when your customer does not know what these ‘generic’ instructions mean in their specific application program. The various problems can include:

1. The customer is not familiar with the tools in their program, and cannot perform the needed steps to prepare the file.

2. You are not interfacing with the person who is actually preparing the file, but an intermediary who neither knows nor cares of what you speak in this area.

3. They don’t know which application program they are using to create the file (note: Mac is not the answer we’re looking for here).

4. The file has been prepared prior to the instructions’ delivery.

5. The application program being used is not able to generate a useable file for the sign (for example, Microsoft Windows is not a good program to prepare logos in).

6. An unfortunate combination of the above.

 What about Macintosh?

In the event that you need to get your hands on an Apple Macintosh computer with a good variety of graphic arts software titles, there is a local solution in the form of your local Kinko’s shop. Kinko’s is a national entity, with Mac-based machines available for rent at a typical rate of .20 cents per minute. As the typical file conversion can be performed within 5 minutes, this is a bargain compared to purchasing a similar system for in-house use.

Be sure to check out Kinko’s on the internet, located at http://www.kinkos.com for more information on locations and hours (many locations are open 24 hours).

Without a doubt, the single biggest difference between April 2004 and the year 2000 is the rapid adaptation of Adobe Acrobat into a variety of environments, including the Internet and digital printing environments. Acrobat is nothing short of a godsend for downloading properly formatted pages from web sites. It can be of similar value when used as a workflow for the receipt of customer files for large-format digital printing.

The basic advantages of an Acrobat Workflow include:

1. Computing Platform Independence – Mac or PC (or Linux/ Unix for that matter).

2. Application Program Independence – Makes no difference which program originally created the Acrobat PDF file.

3. Freedom from Font Substitution – Fonts should be embedded in the file completely (if the program is set-up properly). This virtually eliminates the font substitution problems which have been with us for years.

4. Smaller (relatively) More Portable Files – Compare the average Acrobat PDF with an EPS file. While both are Postscript at their core, PDF is the more highly compressed format. This makes uploading or downloading these files much less time-consuming.

5. Acrobat files are Ubiquitous – To view Acrobat files, you need only Acrobat Reader, a free program available from Adobe Systems at http://www.adobe.com. To Create or Edit Acrobat files, you can use:

a. Adobe Acrobat version 4 through 6. Note that Adobe Acrobat essentially ‘plugs in’ to any program with a ‘Print’ button. You simply print to Acrobat Distiller to generate the PDF. This gives any application program the ability to create PDF documents!

b. Adobe Illustrator 9 or 10

c. CorelDRAW 10 through 12

Hopefully, the advantages of an Adobe Acrobat Workflow are becoming clear. Still, Acrobat is not a panacea for every situation. Particularly when the customer is providing vector-based data for cutting on your plotter, the receipt of other data sets can be preferable to the Acrobat Workflow.

Important Note regarding EPS files

Importing EPS files into sign and design applications:

When I import an .eps file into my graphics program like CorelDraw, it comes in as a low resolution bitmap but I know it is a vector drawing. Why does it happen, and how do I fix it?

An Encapsulated PostScript (.eps) file is a file that contains a vectored image, a bitmap image, or both. When importing an .eps file into a graphics program (other than Adobe Illustrator) using a general or "All Files" filter, the file will appear as a bitmap image. The reason for this is that many .eps files include a bitmap "header." What you are actually importing through the "All Files" filter is that low resolution bitmap header, NOT THE ACTUAL FILE.

The solution is actually quite simple. The import dialog in most vector graphics program such as CorelDraw or sign making program like FlexiSIGN-Pro, list multiple filters. To import an .eps file, change the import filter (or Type of File) from "All File Types" to "PS, PRN, EPS-PostScript Interpreted." Do NOT choose the EPS-Encapsulated PostScript" filter as you will still only import the bitmap header. The PostScript Interpreter actually parses the file into the vector language before it imports into the graphics program.

It is possible that even if you do all as written above, you are still unable to import an .eps file. Encapsulated PostScript files also are saved in multiple levels. Level 1 files are strictly vectored graphics alone or vectors with low resolution bitmaps. Level 2 files save vectored graphics and higher-resolution (and higher file size) graphics. Level 3 does the same as Level 2 but save much larger file sizes. Some programs can only import up to Level 2 .eps files. If you still cannot import the file, the version of your graphics program may not be able to open the file. CorelDraw 9 and later does open Level 3 PostScript files, as does Adobe Illustrator 8 and above (with Illustrator, you need not import the file to open it). Forward the file to Castek if problems still arise.
With that in mind, we now examine the procedures for file preparation in a variety of commonly used application programs.

Adobe Illustrator version 10

1. Any Text Objects (referred to as ‘type’ in Illustrator need to be first ‘Converted to Curves’. This function is called ‘Create Outlines’ in Illustrator v10.

a. Select the type objects

b. Pull down the Type Menu

c. Click ‘Create Outlines’

2. Save the file as an Illustrator EPS file:

a. File > Save As

b. Choose Illustrator EPS from the list box, then click OK

c. In the EPS Format Options dialog box, click Compatibility to version 7 or 8, and Postscript level 2. Click OK to save the file.

Adobe PhotoShop 7

PhotoShop is clearly the industry standard photo editing application in the graphic arts community. Therefore, most raster-oriented programs have the ability to open/ import the native PhotoShop PSD file. To save a PSD file in PhotoShop, simply pull down the File Menu click Save, and provide a file name.

Alternatively, your customer may choose to save as a TIFF (Tagged Image File Format) data file. These are another good choice, as TIF is a lossless data format. To save a PhotoShop file in the TIF format, simply click the File Menu, and Save As. In the resulting dialog box, in the Format list box, click TIFF, and provide a file name.

Macromedia Freehand 9

1. Convert the text objects to path objects by pulling down the Type Menu > Convert to Path.

2. File Menu > click Export

a. In the resulting dialog, in the area labeled format, choose MS-DOS EPS

b. In the area labeled File Name, create a valid Windows file name, complete with a file extension. (i.e. myfile.EPS).

3. Another option would be to click Save from the File Menu (File > Save) and in the resulting dialog box, click Editable EPS.

4. Give a valid Windows file name (i.e. myfile. EPS).

5. Move the file to a floppy, CD-R, or ZIP media.

CorelDRAW 12

Assuming that you have a current copy of Corel (that is version 11 at this point), the customer need only save their file as a native CorelDRAW CDR file. Note that font issues are still a potential problem; there are two approaches to eliminating the problem with fonts needing to be substituted.

1. One option is to convert the fonts to curves. From the Arrange Menu, with the text items selected, click ‘Convert to Curves’. This is done for any and all text objects.

2. Include the fonts as separate files. Fonts are packaged as TrueType TTF, or Adobe Type 1 PFM/PFB. Note that Adobe fonts require two files (one for screen display and one for printer to output. TyueType uses one file for both. Also note that the fonts need to be installed at the Windows level (through Control Panel > Fonts > File > Install New Font), with no programs running at the time of the install.

Microsoft Office Applications

Microsoft applications such as Word, Excel, Publisher, and PowerPoint are NOT color-aware programs. This means that their handling of colors is completely proprietary, and is essentially closed to other programs. They are not using ICC standards for reproducing colors, and this alone makes it difficult to manage color in Microsoft programs.

All is not lost however. We have created a reference file (PowerPoint Color Tester.pdf) on our web site which lists all of the colors available in the Microsoft programs. Color management can be achieved by printing out the reference file on the media(s) of your choice, and then making color selections from the printed octogon of swatches. This is the same color octagon used in the Microsoft apps themselves.

In the event that a customer wants to provide you with a file from a Microsoft Office application program (Word, Excel, PowerPoint, Publisher), and you do not have that program available on one of your systems (Microsoft Office has been included on the office/ accounting machine for new Signworld owners for the past year or so), the best course of action would be to request that the customer prepare an Adobe Acrobat file by printing to Acrobat Distiller from their application (File > Print > Acrobat Distiller). This generates the Acrobat PDF file which can be used to print to your large-format printer. You can scale the file to the desired size in a variety of ways using this workflow.

Quark Xpress 3.3 (or higher)

Quark Xpress is a widely used application program in the page-layout and publishing segments of the market. Unfortunately, Quark has not opened their file format to allow other applications to read their files. Adobe InDesign version 2 does have an import filter for Quark files, but we have not tested it extensively to have a baseline of experience with it. Another approach that should work nicely is to have the customer prepare an Adobe Acrobat file (requires the full Acrobat program) by printing to Acrobat Distiller. This will output a fully editable PDF file that can be used in printing and potentially cutting applications.

Adobe Acrobat

Many sign shops are new to the Acrobat file format, and the many compelling advantages that the format provides for digital printing and web document distribution. The current release version for Acrobat is version 5 (PDF 1.4). Acrobat version 4 (PDF 1.3) is still in wide use, and we recommend using the Acrobat version 4 settings for optimal compatibility. Adobe Acrobat supports page sizes up to 200 inches in both directions (width and height). 

Recommended File Formats – Application Specific Recommendations

Customer is using:



Ask for this type of file:
Adobe PhotoShop



Native PhotoShop PSD file (or TIF)

Adobe Illustrator



Acrobat PDF (or EPS for cutting)

Adobe InDesign



Acrobat PDF (with all fonts embedded)

Adobe PageMaker



Acrobat PDF (with all fonts embedded)

CorelDraw




Native CDR (with text converted)

Corel Photo PAINT



Native CPT (or TIF)

QuarkXpress




Acrobat PDF via Acrobat Distiller

Microsoft Office apps
Acrobat PDF via Acrobat Distiller (or native 

if you have Office)

Macromedia Freehand
Save as EPS file or PDF via Distiller

Closing Remarks:

We recommend that you take this information and make it available to your customers in the format that you choose. This can include Microsoft Word, Adobe Acrobat, or HTML data for web-based distribution. Note that Word and Acrobat PDF formats are on the CD.

